Tuesday, September 10, 2013

LINUX/UNIX Tutorials Continued ....

LINUX/UNIX Tutorials Continued .... 

 

Please read Our official Blogs for similar information.

Networx Technologies official Blogs :

http://ccnatraininginchandigarh.blogspot.in/

http://networxtech.blogspot.in/

http://ccnachd.blogspot.in/

http://networxtechnologies.blogspot.in/

Official Web Site : www.networx256.com

FB page:
https://www.facebook.com/networx256


5.1 File system security (access rights)

In your unixstuff directory, type
% ls -l (l for long listing!)
You will see that you now get lots of details about the contents of your directory, similar to the example below.
File and directory access rights
Each file (and directory) has associated access rights, which may be found by typing ls -l. Also, ls -lg gives additional information as to which group owns the file (beng95 in the following example):
-rwxrw-r-- 1 ee51ab beng95 2450 Sept29 11:52 file1
In the left-hand column is a 10 symbol string consisting of the symbols d, r, w, x, -, and, occasionally, s or S. If d is present, it will be at the left hand end of the string, and indicates a directory: otherwise - will be the starting symbol of the string.
The 9 remaining symbols indicate the permissions, or access rights, and are taken as three groups of 3.
  • The left group of 3 gives the file permissions for the user that owns the file (or directory) (ee51ab in the above example);
  • the middle group gives the permissions for the group of people to whom the file (or directory) belongs (eebeng95 in the above example);
  • the rightmost group gives the permissions for all others.
The symbols r, w, etc., have slightly different meanings depending on whether they refer to a simple file or to a directory.

Access rights on files.

  • r (or -), indicates read permission (or otherwise), that is, the presence or absence of permission to read and copy the file
  • w (or -), indicates write permission (or otherwise), that is, the permission (or otherwise) to change a file
  • x (or -), indicates execution permission (or otherwise), that is, the permission to execute a file, where appropriate

Access rights on directories.

  • r allows users to list files in the directory;
  • w means that users may delete files from the directory or move files into it;
  • x means the right to access files in the directory. This implies that you may read files in the directory provided you have read permission on the individual files.
So, in order to read a file, you must have execute permission on the directory containing that file, and hence on any directory containing that directory as a subdirectory, and so on, up the tree.

Some examples

-rwxrwxrwx a file that everyone can read, write and execute (and delete).
-rw------- a file that only the owner can read and write - no-one else
can read or write and no-one has execution rights (e.g. your
mailbox file).

5.2 Changing access rights

chmod (changing a file mode)

Only the owner of a file can use chmod to change the permissions of a file. The options of chmod are as follows
Symbol Meaning
u
user
g
group
o
other
a
all
r
read
w
write (and delete)
x
execute (and access directory)
+
add permission
-
take away permission
For example, to remove read write and execute permissions on the file biglist for the group and others, type
% chmod go-rwx biglist
This will leave the other permissions unaffected.
To give read and write permissions on the file biglist to all,
% chmod a+rw biglist

Exercise 5a

Try changing access permissions on the file science.txt and on the directory backups
Use ls -l to check that the permissions have changed.

5.3 Processes and Jobs

A process is an executing program identified by a unique PID (process identifier). To see information about your processes, with their associated PID and status, type
% ps
A process may be in the foreground, in the background, or be suspended. In general the shell does not return the UNIX prompt until the current process has finished executing.
Some processes take a long time to run and hold up the terminal. Backgrounding a long process has the effect that the UNIX prompt is returned immediately, and other tasks can be carried out while the original process continues executing.

Running background processes

To background a process, type an & at the end of the command line. For example, the command sleep waits a given number of seconds before continuing. Type
% sleep 10
This will wait 10 seconds before returning the command prompt %. Until the command prompt is returned, you can do nothing except wait.
To run sleep in the background, type
% sleep 10 &
[1] 6259
The & runs the job in the background and returns the prompt straight away, allowing you do run other programs while waiting for that one to finish.
The first line in the above example is typed in by the user; the next line, indicating job number and PID, is returned by the machine. The user is be notified of a job number (numbered from 1) enclosed in square brackets, together with a PID and is notified when a background process is finished. Backgrounding is useful for jobs which will take a long time to complete.

Backgrounding a current foreground process

At the prompt, type
% sleep 1000
You can suspend the process running in the foreground by typing ^Z, i.e.hold down the [Ctrl] key and type [z]. Then to put it in the background, type
% bg
Note: do not background programs that require user interaction e.g. vi

5.4 Listing suspended and background processes

When a process is running, backgrounded or suspended, it will be entered onto a list along with a job number. To examine this list, type
% jobs
An example of a job list could be
[1] Suspended sleep 1000
[2] Running netscape
[3] Running matlab
To restart (foreground) a suspended processes, type
% fg %jobnumber
For example, to restart sleep 1000, type
% fg %1
Typing fg with no job number foregrounds the last suspended process.

5.5 Killing a process

kill (terminate or signal a process)

It is sometimes necessary to kill a process (for example, when an executing program is in an infinite loop)
To kill a job running in the foreground, type ^C (control c). For example, run
% sleep 100
^C
To kill a suspended or background process, type
% kill %jobnumber
For example, run
% sleep 100 &
% jobs
If it is job number 4, type
% kill %4
To check whether this has worked, examine the job list again to see if the process has been removed.

ps (process status)

Alternatively, processes can be killed by finding their process numbers (PIDs) and using kill PID_number
% sleep 1000 &
% ps
PID TT S TIME COMMAND
20077 pts/5 S 0:05 sleep 1000
21563 pts/5 T 0:00 netscape
21873 pts/5 S 0:25 nedit
To kill off the process sleep 1000, type
% kill 20077
and then type ps again to see if it has been removed from the list.
If a process refuses to be killed, uses the -9 option, i.e. type
% kill -9 20077
Note: It is not possible to kill off other users' processes !!!

Summary

Command Meaning
ls -lag list access rights for all files
chmod [options] file change access rights for named file
command & run command in background
^C kill the job running in the foreground
^Z suspend the job running in the foreground
bg background the suspended job
jobs list current jobs
fg %1 foreground job number 1
kill %1 kill job number 1
ps list current processes
kill 26152 kill process number 26152

Thursday, September 5, 2013

The Most Common Jobs for Cisco CCNP Certified Professionals

The Most Common Jobs for Cisco CCNP Certified Professionals


Please read Our official Blogs for similar information.

Networx Technologies official Blogs :

http://ccnatraininginchandigarh.blogspot.in/

http://networxtech.blogspot.in/

http://ccnachd.blogspot.in/

http://networxtechnologies.blogspot.in/

Official Web Site : www.networx256.com

FB page: https://www.facebook.com/networx256

------------------------------------------------------------
-------------------------------------



The economy might still be limping along, but the IT industry remains as healthy as ever. IT outsourcing companies have become popular in recent years, but larger companies from hospitals to manufacturers are also hiring for a continually growing workforce of in-house IT professionals. If anything, the high job demand present in the early ’00s has increased since the 2008 recession. Networking, a distinct career path in IT, remains one of the main stays.

Cisco Certified Network Professional

CCNP certification requires IT employees to pass three exams: ROUTE, SWITCH, and TSHOOT. The CCNP certification asserts that the professional knows how to install, repair, and maintain Cisco networking equipment. They can design local and wide area networks, create virtual networks, and can integrate voice and video services.
Although there are dozens of networking certifications, CCNP certification remains in demand due to the prevalence of Cisco networking equipment, the difficulty of the exam and the fact that people who can work on Cisco routers, can pretty much work on the majority of the competition’s routers. CCNP certification holders often pursue other Cisco certifications including CCDP, which focuses on designing networking, and CCNP variants like CCNP Security and CCNP Wireless. These additional certifications provide CCNP certified professionals with clear specialization and advancement opportunities.

Network Engineer

Network engineers ensure that their networks always run smoothly. They must understand the ins and outs of networking from infrastructure to security, and they help organize the company’s various networking teams. A network engineer does a little bit of everything from helping to design the network to making sure that end-users can connect and aren’t running into significant congestion.

Systems Engineers

Systems engineers are similar to network engineers, but they typically focus more on designing and installing networks rather than monitoring them. Both systems and network engineers lead networking teams. They organize projects and help out where needed, and they keep track of a company’s networking infrastructure. Because systems and network engineers have very similar jobs, the two titles are often used interchangeably.

Network Technician

Technicians handle the day-to-day tasks of running a network. There will often be some overlap between an engineer’s duties and those of a technician, but for the most part, technicians are responsible for repairing equipment like routers, installing new cables, and troubleshooting problems on the spot. Technicians can configure routers at the end-user’s location and install software, and they can also assist network and systems engineers in installing new infrastructure.
For complex and difficult problems, technicians can escalate the issue to network engineers or administrators, who are typically more experienced and are better equipped to handle such problems. Technicians should have a firm understanding of networking protocols and equipment standards, and they need to have the patience and expertise required to diagnose and solve common networking issues.
Network administrators are similar to both network engineers and network technicians. They work directly with the end-user to solve local issues, but they also monitor the entire network. Administrators tend to have greater access within a network to diagnose issues and solve them, so technicians will often turn to network administrators for problems they cannot solve themselves.

Support Engineer

Support engineers fulfill a very different role. Instead of visiting job sites directly, they offer phone, live chat, or e-mail support for clients. They still need to understand networking protocols and equipment, but they won’t repair faulty equipment themselves.
They should have strong communications skills to communicate clearly with end-users of varying technical backgrounds including clients who may know little or nothing about the products or services they are using. Some support engineers will also use remote access services to view client computer and router information and troubleshoot software and hardware issues.
Like network technicians, support engineers will occasionally escalate difficult issues to network engineers and administrators, but they can resolve most support tickets on their own. They will also need to instruct clients on how to operate their equipment and perform updates.

Tuesday, September 3, 2013

UNIX Tutorial Day 2

UNIX Tutorial Day 2

1.1 Listing files and directories

ls (list)

When you first login, your current working directory is your home directory. Your home directory has the same name as your user-name, for example, ee91ab, and it is where your personal files and subdirectories are saved.
To find out what is in your home directory, type
% ls
The ls command ( lowercase L and lowercase S ) lists the contents of your current working directory.
Unix Terminal - running the ls command
There may be no files visible in your home directory, in which case, the UNIX prompt will be returned. Alternatively, there may already be some files inserted by the System Administrator when your account was created.
ls does not, in fact, cause all the files in your home directory to be listed, but only those ones whose name does not begin with a dot (.) Files beginning with a dot (.) are known as hidden files and usually contain important program configuration information. They are hidden because you should not change them unless you are very familiar with UNIX!!!
To list all files in your home directory including those whose names begin with a dot, type
% ls -a
As you can see, ls -a lists files that are normally hidden.
Unix Terminal - running the ls command
ls is an example of a command which can take options: -a is an example of an option. The options change the behaviour of the command. There are online manual pages that tell you which options a particular command can take, and how each option modifies the behaviour of the command. (See later in this tutorial)

1.2 Making Directories

mkdir (make directory)

We will now make a subdirectory in your home directory to hold the files you will be creating and using in the course of this tutorial. To make a subdirectory called unixstuff in your current working directory type
% mkdir unixstuff
To see the directory you have just created, type
% ls

1.3 Changing to a different directory 

cd (change directory)

The command cd directory means change the current working directory to 'directory'. The current working directory may be thought of as the directory you are in, i.e. your current position in the file-system tree.
To change to the directory you have just made, type
% cd unixstuff
Type ls to see the contents (which should be empty)

Exercise 1a

Make another directory inside the unixstuff directory called backups

1.4 The directories . and ..

Still in the unixstuff directory, type
% ls -a
As you can see, in the unixstuff directory (and in all other directories), there are two special directories called (.) and (..)

The current directory (.)

In UNIX, (.) means the current directory, so typing
% cd .
NOTE: there is a space between cd and the dot
means stay where you are (the unixstuff directory).
This may not seem very useful at first, but using (.) as the name of the current directory will save a lot of typing, as we shall see later in the tutorial.

The parent directory (..)

(..) means the parent of the current directory, so typing
% cd ..
will take you one directory up the hierarchy (back to your home directory). Try it now.
Note: typing cd with no argument always returns you to your home directory. This is very useful if you are lost in the file system.

1.5 Pathnames

pwd (print working directory)

Pathnames enable you to work out where you are in relation to the whole file-system. For example, to find out the absolute pathname of your home-directory, type cd to get back to your home-directory and then type
% pwd
The full pathname will look something like this -
/home/its/ug1/ee51vn
which means that ee51vn (your home directory) is in the sub-directory ug1 (the group directory),which in turn is located in the its sub-directory, which is in the home sub-directory, which is in the top-level root directory called " / " .
Unix File structure

Exercise 1b

Use the commands cd, ls and pwd to explore the file system.
(Remember, if you get lost, type cd by itself to return to your home-directory)

1.6 More about home directories and pathnames

Understanding pathnames

First type cd to get back to your home-directory, then type
% ls unixstuff
to list the conents of your unixstuff directory.
Now type
% ls backups
You will get a message like this -
backups: No such file or directory
The reason is, backups is not in your current working directory. To use a command on a file (or directory) not in the current working directory (the directory you are currently in), you must either cd to the correct directory, or specify its full pathname. To list the contents of your backups directory, you must type
% ls unixstuff/backups

~ (your home directory)

Home directories can also be referred to by the tilde ~ character. It can be used to specify paths starting at your home directory. So typing
% ls ~/unixstuff
will list the contents of your unixstuff directory, no matter where you currently are in the file system.
What do you think
% ls ~
would list?
What do you think
% ls ~/..
would list?

Summary

Command Meaning
ls list files and directories
ls -a list all files and directories
mkdir make a directory
cd directory change to named directory
cd change to home-directory
cd ~ change to home-directory
cd .. change to parent directory
pwd display the path of the current directory

Monday, September 2, 2013

UNIX/Linux Beginners Guide ( Day 1 )

 

 UNIX/Linux Beginners Guide ( Day 1 )

UNIX Introduction

What is UNIX?

UNIX® License PlateUNIX is an operating system which was first developed in the 1960s, and has been under constant development ever since. By operating system, we mean the suite of programs which make the computer work. It is a stable, multi-user, multi-tasking system for servers, desktops and laptops.
UNIX systems also have a graphical user interface (GUI) similar to Microsoft Windows which provides an easy to use environment. However, knowledge of UNIX is required for operations which aren't covered by a graphical program, or for when there is no windows interface available, for example, in a telnet session.

Types of UNIX

The Linux PenguinThere are many different versions of UNIX, although they share common similarities. The most popular varieties of UNIX are Sun Solaris, GNU/Linux, and MacOS X.
Here in the School, we use Solaris on our servers and workstations, and Fedora Linux on the servers and desktop PCs.

The UNIX operating system

The UNIX operating system is made up of three parts; the kernel, the shell and the programs.

The kernel

The kernel of UNIX is the hub of the operating system: it allocates time and memory to programs and handles the filestore and communications in response to system calls.
As an illustration of the way that the shell and the kernel work together, suppose a user types rm myfile (which has the effect of removing the file myfile). The shell searches the filestore for the file containing the program rm, and then requests the kernel, through system calls, to execute the program rm on myfile. When the process rm myfile has finished running, the shell then returns the UNIX prompt % to the user, indicating that it is waiting for further commands.

The shell

The shell acts as an interface between the user and the kernel. When a user logs in, the login program checks the username and password, and then starts another program called the shell. The shell is a command line interpreter (CLI). It interprets the commands the user types in and arranges for them to be carried out. The commands are themselves programs: when they terminate, the shell gives the user another prompt (% on our systems).
The adept user can customise his/her own shell, and users can use different shells on the same machine. Staff and students in the school have the tcsh shell by default.
The tcsh shell has certain features to help the user inputting commands.
Filename Completion - By typing part of the name of a command, filename or directory and pressing the [Tab] key, the tcsh shell will complete the rest of the name automatically. If the shell finds more than one name beginning with those letters you have typed, it will beep, prompting you to type a few more letters before pressing the tab key again.
History - The shell keeps a list of the commands you have typed in. If you need to repeat a command, use the cursor keys to scroll up and down the list or type history for a list of previous commands.

Files and processes

Everything in UNIX is either a file or a process.
A process is an executing program identified by a unique PID (process identifier).
A file is a collection of data. They are created by users using text editors, running compilers etc.
Examples of files:
  • a document (report, essay etc.)
  • the text of a program written in some high-level programming language
  • instructions comprehensible directly to the machine and incomprehensible to a casual user, for example, a collection of binary digits (an executable or binary file);
  • a directory, containing information about its contents, which may be a mixture of other directories (subdirectories) and ordinary files.

The Directory Structure

All the files are grouped together in the directory structure. The file-system is arranged in a hierarchical structure, like an inverted tree. The top of the hierarchy is traditionally called root (written as a slash / )
Unix File Structure
In the diagram above, we see that the home directory of the undergraduate student "ee51vn" contains two sub-directories (docs and pics) and a file called report.doc.
The full path to the file report.doc is "/home/its/ug1/ee51vn/report.doc"

Starting an UNIX terminal

To open an UNIX terminal window, click on the "Terminal" icon from Applications/Accessories menus.
Gnome Menus

An UNIX Terminal window will then appear with a % prompt, waiting for you to start entering commands.
Unix Terminal window

Thursday, August 29, 2013

How to Prepare for Cisco CCNP R&S

How to Prepare for Cisco CCNP R&S

Cisco’s CCNP R&S track currently has 3 exams, ROUTE, SWITCH and TSHOOT. Pass all 3 exams and you will be CCNP R&S certified. I receive many questions from students asking what the best method is to study these exams and how to prepare themselves. In this article I’ll explain what you will encounter on the exams and the best way to pass the exams.

Knowledge Foundation

Before I dive into CCNP R&S, let’s talk a little bit about CCNA R&S first. I am going to assume that you passed the CCNA exam and now you are looking to become CCNP R&S certified. Before you start with the CCNP material, you should consider if your “knowledge foundation” is strong enough. Most of the topics in CCNP are not new but will be more in-depth than what you learned from CCNA. To illustrate this, take a good look at the Cisco certification pyramid:
Cisco Pyramid
Most students don’t pay a lot of attention to this picture but if you take a good look, you’ll see that CCNA is the largest part of the pyramid. If you want to pass the CCNP exams you will have to be absolutely 100% comfortable with the things you learned in CCNA R&S. If it’s been awhile since you became CCNA certified, please do yourself a favor and re-read your CCNA material or do some more CCNA level labs. If you have difficulty doing subnetting questions without a calculator or have no idea anymore how spanning-tree, frame-relay, OSPF and EIGRP work…then CCNP will be a very bumpy ride. If you are familiar with everything from CCNA then CCNP will be a very enjoyable ride! Be honest with yourself, even if you passed the CCNA exam…if you had some difficulties with certain topics, visit those again and make sure you have no knowledge gaps. If you want to learn how to ride a motorcycle, you should start learning how to ride a bike…having said that, let’s look at the CCNP R&S exams!

ROUTE

Let’s start with an overview of all the major ROUTE topics:
  • EIGRP Packets and Metrics
  • EIGRP Summarization
  • EIGRP over Frame-Relay
  • EIGRP Authentication
  • EIGRP Advanced Features
  • OSPF LSA Types
  • OSPF Summarization
  • OSPF Special Area Types
  • OSPF Authentication
  • OSPF Virtual Links
  • Routing Manipulation
  • Redistribution
  • BGP (Border Gateway Protocol)
  • IPv6 Routing Protocols
  • IPv6 Tunneling
In short the ROUTE exam is about EIGRP, OSPF, some routing “manipulation”, BGP and IPv6. You already learned about EIGRP and OSPF and a little bit of IPv6 in CCNA so these should be familiar topics, you will learn (a lot) more about them however. For example, in CCNA you learned about OSPF and its LSDB (Link State Database) but in CCNP you will take a close look at all the LSA types that fill the LSDB. You learned about IPv6 in CCNA but now you will also learn some migration and tunneling techniques so you can connect IPv6 networks over existing IPv4 networks. If you forgot about the difference between EIGRP/OSPF and things like “link state” vs “distance vector” then please re-visit the CCNA material before you dive into ROUTE.
My recommendation is to start with the ROUTE exam first, since you will find some routing-related topics in the SWITCH exam while there are no “switch” topics in the ROUTE exam. Also, you won’t need any hardware to study for this exam since you can do everything with the GNS3 router emulator!

SWITCH

Let me show you the major topics of the SWITCH exam:
  • VLANs and Trunking
  • Private VLANs
  • Spanning-Tree Basics
  • Rapid Spanning-Tree
  • MST (Multiple Spanning-Tree)
  • Spanning Tree Toolkit
  • Etherchannel (Link Aggregation)
  • InterVLAN Routing
  • Gateway Redundancy (VRRP, GLBP, HSRP)
  • Switch Security
  • VoIP / Video on Switched Networks (Quality of Service)
  • Wireless
Some of these topics should ring a bell, you learned about VLANs and Trunks from CCNA but you’ll learn some more about them. Spanning-tree should be familiar but you will learn about the different flavors like “rapid” spanning-tree and Multiple spanning-tree in-depth. Etherchannels were mentioned in CCNA but now you’ll learn about the different types and how to configure them. There are also some “multilayer” switch topics like routing between VLANs and creating virtual gateways for clients using VRRP, GLBP and HSRP. In CCNA you learned about port-security which is also in the SWITCH exam but you’ll also learn about DHCP and ARP snooping. Last but not least you will learn how to prepare your switched network for Voice over IP, Video and/or wireless networking.
If you are fuzzy about spanning-tree and its port states like the designated, non-designated, root port, port priority and such…please take a look at the CCNA material again before you start with SWITCH!
To study SWITCH at home you will need some real hardware switches. GNS3 can only emulate routers and the NM-16ESW switch module which doesn’t support rapid spanning tree, multiple spanning-tree or the different etherchannel protocols. You don’t need expensive hardware, my recommendation is to buy 2x Cisco Catalyst 2950 switches and 1x Cisco Catalyst 3550 switch.  Most of it also applies for the CCNP SWITCH exam.

TSHOOT

The TSHOOT exam is different compared to what you have seen so far. The ROUTE and SWITCH exams are similar to CCNA, you will get some multiple choice questions, labs, click-all-that-apply questions, etc.
TSHOOT is different as the exam will present you with a (large) network topology that has a number of issues. You don’t have to fix these issues but you have to be able to look at the configurations of the devices and answer what the problem is. If you want to pass this exam there are two things you will have to do:
  • Truly understand all the topics that you learned in CCNA, ROUTE and SWITCH.
  • Become familiar with the topology that Cisco uses in the TSHOOT exam.
There is no “magic” troubleshooting technique that will help you solve any problem. The only way to become good at troubleshooting is understanding all the protocols and how they work together. You can become good at troubleshooting by doing labs, labs and even more labs!
Cisco released the TSHOOT exam topology to the public, take a good look at it to understand all the different components. You don’t want to see this topology for the first time when you are doing the exam…
Look at all the different protocols that are running, how they work together and the exam will be a LOT easier.

CCNP Study Strategy

You now have an idea what the exams are about, and that it’s best to start with ROUTE, SWITCH and finish with TSHOOT. So where do you start?
Buy some CCNP ROUTE study material like a book or some training videos, whatever you prefer.  While you are studying for ROUTE you have time to browse Ebay or something to “hunt” for your switches that you’ll need for the SWITCH exam.
As you are reading, try to stick to one topic at a time, and don’t read the book from front to back right away. As you are reading and learning about a topic or feature, try to configure it yourself on your GNS3 routers or switches and make sure you understand what you are doing. Look at some show commands, try some debugs. I can’t emphasize enough how important it is to do labs, labs and even more labs. Most people make the mistake of trying to “brute force” all the theory in their head and doing not enough labs. 
Doing labs is also a lot more fun than just reading books or watching videos…If you want labs to practice instead of building your own.
Also as you are working your way through a chapter, make sure to take notes:

  • Take notes (I use notepad) to write down some of the commands that you have difficulty with remembering. This helps to speed up doing labs.
Once you feel you mastered a topic, move on to the next chapter. Try to focus on 1 item at the time instead of reading about everything at the same time, focusing is your friend when it comes to studying.

FAQ

Q: Is is possible to become CCNP R&S certified with self-study?
A: Definitely yes! Because of GNS3 it’s easy to practice all router protocols on your own computers and with a couple of switches you will have all the equipment you need. It will take self discipline to work yourself through the material since you are not “forced” to be in the classroom and attending a course.
Q: How much studying time does it take to pass the CCNP exams?
A: This is a difficult question to answer as it is different for everyone. It depends on how much experience you have in IT / networking and how easily you can memorize information. Roughly I think it will take anywhere between 100-200 hours or so to study ROUTE and SWITCH each (so that’s 200-400 hours for both!) and TSHOOT maybe 50-100 hours. This includes reading books, perhaps watching videos, doing labs, reviewing notes, etc.
Q: What is the best studying material to use? Classroom training, reading books or watching videos?
A: If you are completely new to a topic then classroom training is probably the best method since you will have someone in front of you that explains everything. When you don’t understand something you can just ask it and it will be explained to you until you understand it. The downside of classroom training is that it’s quite expensive and depending on the other students the course might run too slow or too fast for you. Watching videos also works very well when a certain topic is new to you, I wouldn’t recommend watching them if you are looking to fill some “knowledge gaps” as you will have that “I already know this” feeling when watching the video and get bored easily. Personally I like books best because I can speed up or slow down reading exactly when I want to. Most networking books can be very difficult to get through if something is new to you however. In short, if you are new to something…classroom training will be great. If you go for the self-study path, see if you can watch some videos and then move on to reading books.
Q: How much time should I spend watching videos or reading books vs doing labs?
A: The short answer is that I think you should spend roughly 80% of your time doing labs and 20% of your time watching videos or reading books. 
Q: What hardware should I buy?
A: Don’t buy any hardware for the ROUTE exam, you can do everything with GNS3. For the SWITCH exam the cheapest solution is to buy 2x Cisco Catalyst 2950 switches and 1x Cisco Catalyst 3550 switch.  Most of it applies for the CCNP SWITCH exam as well.
Q: In what order should I do the CCNP R&S exams?
A: I think it’s best to start with ROUTE, then SWITCH and finish with TSHOOT. The reason for this is that you will find some “routing” topics in the SWITCH exam. In CCNP R&S you will learn about multilayer switches in the SWITCH exam so it’s best to understand routing before you approach this topic. Even if you decide to do SWITCH first, it doesn’t matter all too much since multilayer switching will be easy to understand if you passed the CCNA R&S exam.

Summary

After reading this article I am sure you will have many other questions, things that I didn’t even think about when I wrote this. Feel free to ask anything and I will update this article to answer your question(s)!

Tuesday, August 27, 2013

Cisco Router Boot up Process :

Cisco Router Boot up Process :


Please read Our official Blogs for similar information.

 Networx Technologies official Blogs :

http://ccnatraininginchandigarh.blogspot.in/

http://networxtech.blogspot.in/

http://ccnachd.blogspot.in/

http://networxtechnologies.blogspot.in/


Official Web Site : www.networx256.com

FB page: https://www.facebook.com/networx256

----------------------------------------------------------------------------
 




In this article we will learn about the main components of a Cisco router and how the boot process takes place.
Types of memory
Generally Cisco routers (and switches) contain four types of memory:
Read-Only Memory (ROM): ROM stores the router’s bootstrap startup program, operating system software, and power-on diagnostic test programs (POST).
Flash Memory: Generally referred to simply as “flash”, the IOS images are held here. Flash is erasable and reprogrammable ROM. Flash memory content is retained by the router on reload.
Random-Access Memory (RAM): Stores operational information such as routing tables and the running configuration file. RAM contents are lost when the router is powered down or reloaded. By default, routers look here first for an Internetwork Operating System (IOS) file during boot.
Non-volatile RAM (NVRAM): NVRAM holds the router’s startup configuration file. NVRAM contents are not lost when the router is powered down or reloaded.

Some comparisons to help you remember easier:
+ RAM is a volatile memory so contents are lost on reload, where NVRAM and Flash contents are not.
+ NVRAM holds the startup configuration file, where RAM holds the running configuration file.
+ ROM contains a bootstrap program called ROM Monitor (or ROMmon). When a router is powered on, the bootstrap runs a hardware diagnostic called POST (Power-On Self Test).

Router boot process
The following details the router boot process:
1. The router is powered on.
2. The bootstrap program (ROMmon) in ROM runs Power-On Self Test (POST)
3. The bootstrap checks the Configuration Register value to specify where to load the IOS. By default (the default value of Configuration Register is 2102, in hexadecimal), the router first looks for “boot system” commands in startup-config file. If it finds these commands, it will run boot system commands in order they appear in startup-config to locate the IOS. If not, the IOS image is loaded from Flash . If the IOS is not found in Flash, the bootstrap can try to load the IOS from TFTP server or from ROM (mini-IOS).
4. After the IOS is found, it is loaded into RAM.
5. The IOS attempts to load the configuration file (startup-config) from NVRAM to RAM. If the startup-config is not found in NVRAM, the IOS attempts to load a configuration file from TFTP. If no TFTP server responds, the router enters Setup Mode (Initial Configuration Mode).

Cisco_Boot_Sequence.jpg
And this is the process we can see on our screen when the router is turned on:
Cisco_router_boot_process.jpg
In short, when powered on the router needs to do:
1. Run POST to check hardware
2. Search for a valid IOS (the Operating System of the router)
3. Search for a configuration file (all the configurations applied to this router)

Specify how much RAM, NVRAM and Flash of a router

Also, from the information shown above, we can learn some information about router’s model, RAM, Flash, NVRAM memories as shown below:
RAM_ROM_Flash_memory.jpg
Note: The “show version” command also gives us this information.
All the above information is straight-forwarding except the information of RAM. In some series of routers, the RAM information is displayed by 2 parameters (in this case 60416K/5120K). The first parameter indicates how much RAM is in the router while the second parameter (5120K) indicates how much DRAM is being used for Packet memory. Packet memory is used for buffering packets.
So, from the output above we can learn:
Amount of RAM: 60416 + 5120 = 65536KB / 1024 = 64MB
Amount of NVRAM: 239KB
Amount of Flash: 62720KB

Monday, August 26, 2013

EIGRP LAB Scenario

EIGRP LAB Scenario


Please read Our official Blogs for similar information.



 Networx Technologies official Blogs :

http://ccnatraininginchandigarh.blogspot.in/

http://networxtech.blogspot.in/

http://ccnachd.blogspot.in/

http://networxtechnologies.blogspot.in/


Official Web Site : www.networx256.com

FB page: https://www.facebook.com/networx256

----------------------------------------------------------------------------



EIGRP is a Cisco-proprietary routing protocol for TCP/IP. It's actually based on Cisco's proprietary IGRP routing protocol, with many enhancements built into it. Because it has its roots in IGRP, the configuration is similar to IGRP; however, it has many link state characteristics that were added to it to allow EIGRP to scale to enterprise network sizes. To know these characteristics read our previous article.
In this article I will demonstrate an example of EIGRP Routing configurations. We will use four different series router so you can get familiar with all different platform covered in CCNA exam. Create a topology as shown in figure.
static route configurations
1841 Series Router0 (R1)

FastEthernet0/0Serial0/0/0
IP address10.0.0.120.0.0.1
Connected WithPc0R2 on Serial 0/0
2811 Series Router0 (R4)

FastEthernet0/0Serial0/0/0
IP address50.0.0.140.0.0.2
Connected WithPc1R3 on Serial 0/0
2621XM Series Router0 (R3)

FastEthernet0/0Serial0/0/0
IP address30.0.0.240.0.0.1
Connected WithFastEthernet0/0R4 on Serial 0/0/0
2620XM Series Router1 (R2)

FastEthernet0/0Serial0/0
IP address30.0.0.120.0.0.2
Connected WithR3 on FastEthernet0/0R1 on Serial 0/0/0
PC-PT PC0

FastEthernet0Default Gateway
IP address10.0.0.210.0.0.1
Connected WithR1 on FastEthernet0/0
PC-PT PC1

FastEthernet0Default Gateway
IP address50.0.0.250.0.0.1
Connected WithR4 on FastEthernet0/0
To configure any router double click on it and select CLI.To configure this topology use this step by step guide.

(1841Router0) Hostname R1

To configure and enable eigrp routing on R1 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit
R1(config)#

(2620XM-Router1) Hostname R2

To configure and enable eigrp routing on R2 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface serial 0/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config)#router eigrp 1
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit
R2(config)#

(2620XM-Router2)Hostname R3

To configure and enable eigrp routing on R3 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#interface serial 0/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#clock rate 64000
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
R3(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3(config)#router eigrp 1
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
R3(config)#

(2811Router3) Hostname R4

To configure and enable eigrp routing on R4 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 40.0.0.2 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config-if)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 50.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
R3(config)#router eigrp 1
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
R3(config)#

PC-1

PC>ipconfig

IP Address......................: 10.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 10.0.0.1

PC>ping 50.0.0.2

Pinging 50.0.0.2 with 32 bytes of data:

Reply from 50.0.0.2: bytes=32 time=156ms TTL=124
Reply from 50.0.0.2: bytes=32 time=127ms TTL=124
Reply from 50.0.0.2: bytes=32 time=156ms TTL=124
Reply from 50.0.0.2: bytes=32 time=140ms TTL=124

Ping statistics for 50.0.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 127ms, Maximum = 156ms, Average = 144ms
PC>

PC-2

PC>ipconfig

IP Address......................: 50.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 50.0.0.1

PC>ping 10.0.0.2

Pinging 10.0.0.2 with 32 bytes of data:

Reply from 10.0.0.2: bytes=32 time=140ms TTL=124
Reply from 10.0.0.2: bytes=32 time=141ms TTL=124
Reply from 10.0.0.2: bytes=32 time=157ms TTL=124
Reply from 10.0.0.2: bytes=32 time=156ms TTL=124

Ping statistics for 10.0.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 140ms, Maximum = 157ms, Average = 148ms
You can verify that eigrp is running successfully via show ip protocols command in privilege mode.
R4#show ip protocols

Routing Protocol is "ospf 4"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 50.0.0.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    50.0.0.0 0.255.255.255 area 0
    40.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    40.0.0.1             110      00:01:26
  Distance: (default is 110)

R4#
You can use show ip route command to troubleshoot eigrp network. If you did not see information about any route checks the router attached with that network.
R4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O    10.0.0.0/8 [110/1564] via 40.0.0.1, 00:02:37, Serial0/0/0
O    20.0.0.0/8 [110/1563] via 40.0.0.1, 00:02:37, Serial0/0/0
O    30.0.0.0/8 [110/782] via 40.0.0.1, 00:02:37, Serial0/0/0
C    40.0.0.0/8 is directly connected, Serial0/0/0
C    50.0.0.0/8 is directly connected, FastEthernet0/0
R4#
To test eigrp routing do ping from pc1 to pc2 and vice versa. If you get replay then you have successfully configured eigrp routing but if you did not get replay double check this configuration and try to troubleshoot. I have uploaded a configured and tested topology in case you are unable to locate the problem spot then download this configuration file. And try to find out where have you committed mistake

eigrp routing configurations

Configuration command of EIGRP

CommandsDescriptions
Router(config)#router eigrp 1Turns on the EIGRP process. 1 is the autonomous system number, which can be a number between 1 and 65,535.
Note:- All routers in the same autonomous system must use the same autonomous system number.
Router(config-router)#network 10.0.0.0Specifies which network to advertise in EIGRP.
Router(config-if)#bandwidth xSets the bandwidth of this interface to x kilobits to allow EIGRP to make a better metric calculation
TIP: The bandwidth command is used for metric calculations only. It does not change interface performance.
Router(config-router)#no network 10.0.0.0Removes the network from the EIGRP process.
Router(config)#no router eigrp 1Disables routing process 1
Router(config-router)#auto-summaryEnables auto-summarization for the EIGRP process.
Router(config-router)#no autosummaryTurns off the auto-summarization feature.
Router(config-router)#variance ninclude routes with a metric less than or equal to n times the minimum metric route for that destination, where n is the number specified by the variance command
NOTE: If a path is not a feasible successor, it is not used in load balancing. EIGRP supports up to six unequal-cost paths.
Router(config)#interface serial 0/0Enters interface configuration mode.
Router(config-if)#bandwidth 256Sets the bandwidth of this interface to 256 kilobits to allow EIGRP to make a better metric calculation.
Router#show ip eigrp neighborsDisplays the neighbor table.
Router#show ip eigrp neighbors detailDisplays a detailed neighbor table.
Router#show ip eigrp interfacesShows information for each interface
Router#show ip eigrp interfaces serial 0/0Shows information for a specific interface
Router#show ip eigrp interfaces 1Shows information for interfaces running process 1.
Router#show ip eigrp topologyDisplays the topology table
Router#show ip eigrp trafficShows the number and type of packets sent and received
Router#show ip route eigrpShows a routing table with only EIGRP entries
Router#debug eigrp fsmDisplays events/actions related to EIGRP feasible successor metrics (FSM)
Router#debug eigrp packetDisplays events/actions related to EIGRP packets
Router#debug eigrp neighborDisplays events/actions related to your EIGRP neighbors
Router#debug ip eigrp neighborDisplays events/actions related to your EIGRP neighbors
Router#debug ip eigrp notificationsDisplays EIGRP event notifications